24 lines
529 B
Nix
24 lines
529 B
Nix
{ pkgs, lib, ... }:
|
|
|
|
with pkgs.lib;
|
|
pkgs.buildGoApplication rec {
|
|
pname = "google-photo-uploader";
|
|
version = "1.6.1";
|
|
|
|
src = pkgs.fetchFromGitHub {
|
|
owner = "int128";
|
|
repo = "gpup";
|
|
rev = version;
|
|
sha256 = "sha256-FfJbWpH//Z/NxgpH7JvOf8pWxJOxgYDABUfcyWNps30=";
|
|
};
|
|
|
|
modules = ./gomod2nix.toml;
|
|
|
|
meta = {
|
|
description = "Google photos uploader, written in Go.";
|
|
homepage = "https://github.com/int128/gpup";
|
|
license = licenses.asl20;
|
|
platforms = platforms.linux ++ platforms.darwin;
|
|
};
|
|
}
|