hardwareModules: hostname:
{ ... }:
with hardwareModules;
{
imports = if (hostname == "system3") then [
common-cpu-amd
common-gpu-amd
common-pc-ssd
] else if (hostname == "jazz") then [
] else
[ ];
}