82 lines
1.8 KiB
Nix
82 lines
1.8 KiB
Nix
{ config, lib, pkgs, modulesPath, ... }:
|
|
|
|
{
|
|
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
|
|
|
|
boot = {
|
|
initrd = {
|
|
availableKernelModules =
|
|
[ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
|
|
kernelModules = [ ];
|
|
};
|
|
loader = {
|
|
systemd-boot.enable = true;
|
|
efi.canTouchEfiVariables = true;
|
|
};
|
|
kernelModules = [ "kvm-amd" ];
|
|
extraModulePackages = [ ];
|
|
};
|
|
|
|
fileSystems = {
|
|
"/" = {
|
|
device = "jazz-root";
|
|
fsType = "tmpfs";
|
|
options = [ "mode=755" "noexec" ];
|
|
};
|
|
|
|
"/boot" = {
|
|
device = "/dev/disk/by-label/JAZZ-BOOT";
|
|
fsType = "vfat";
|
|
options = [ "noatime" "noexec" ];
|
|
};
|
|
|
|
"/nix" = {
|
|
device = "/dev/disk/by-label/jazz-data";
|
|
fsType = "btrfs";
|
|
options = [ "subvol=@nix" "noatime" "compress=zstd" ];
|
|
};
|
|
|
|
"/state" = {
|
|
device = "/dev/disk/by-label/jazz-data";
|
|
fsType = "btrfs";
|
|
options = [ "subvol=@state" "noatime" "compress=zstd" ];
|
|
};
|
|
|
|
"/home" = {
|
|
device = "/dev/disk/by-label/jazz-data";
|
|
fsType = "btrfs";
|
|
options = [ "subvol=@home" "noatime" "compress=zstd" ];
|
|
};
|
|
|
|
"/var/log" = {
|
|
device = "/dev/disk/by-label/jazz-data";
|
|
fsType = "btrfs";
|
|
options = [ "subvol=@log" "noatime" "compress=zstd" "noexec" ];
|
|
};
|
|
|
|
"/var/lib/tailscale" = {
|
|
device = "/dev/disk/by-label/jazz-data";
|
|
fsType = "btrfs";
|
|
options = [ "noatime" "compress=zstd" "noexec" "subvol=@tailscale" ];
|
|
};
|
|
};
|
|
|
|
swapDevices = [{ device = "/dev/disk/by-label/jazz-swap"; }];
|
|
|
|
hardware = {
|
|
enableAllFirmware = true;
|
|
cpu.amd.updateMicrocode = true;
|
|
};
|
|
|
|
networking = {
|
|
useDHCP = false;
|
|
macvlans = {
|
|
intif0 = {
|
|
interface = "enp5s0";
|
|
mode = "bridge";
|
|
};
|
|
};
|
|
interfaces.intif0.macAddress = "02:57:9a:a4:10:d3";
|
|
};
|
|
}
|