nixos-config/config/hardware/cashew.nix

24 lines
388 B
Nix

{ config, lib, pkgs, ... }:
{
config = {
boot.isContainer = true;
networking = {
useDHCP = false;
macvlans = {
extif0 = {
interface = "eno2";
mode = "bridge";
};
};
interfaces = {
extif0.macAddress =
pkgs.lib.network.generate-mac-address config.instance.hostname "extif0";
};
};
};
}