31 lines
865 B
Nix
31 lines
865 B
Nix
{
|
|
description = "Worther - Calculate cryptocurrency taxes & net worth.";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-21.05";
|
|
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
# outputs = { self, nixpkgs, flake-utils, ... }: with nixpkgs.lib; let
|
|
# system = "x86_64-linux";
|
|
# pkgs = import nixpkgs { inherit system; };
|
|
# worther = pkgs.callPackage ./worther.nix { pkgs = pkgs; };
|
|
# in rec {
|
|
# packages.${system}.worther = worther;
|
|
# defaultPackage = packages.${system}.worther;
|
|
# };
|
|
|
|
outputs = { self, nixpkgs, flake-utils, ... }:
|
|
with nixpkgs.lib;
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let pkgs = import nixpkgs { inherit system; };
|
|
|
|
in {
|
|
packages = rec {
|
|
default = worther;
|
|
worther = pkgs.callPackage ./worther.nix { pkgs = pkgs; };
|
|
};
|
|
});
|
|
}
|